ObjectWeb Consortium
Search ObjectWeb Mail Archive: 

Advanced Search - Powered by Google


Mail Archive Home | c-jdbc List | May 2005 Index

<--  Date Index  --> <--  Thread Index  -->

Re: [c-jdbc] Problems Executing Stored Procedures in release 1.3


On Mon, May 30, 2005 at 04:41:46PM -0700, Dylan Hansen wrote:

> I've checked out the code this morning and setting  
> driverProcessed=false in our connection URL now works properly.  That  
> being said, I am now having a few issues that I didn't see at the end  
> of last week.  All of these issues occur when driverProcessed is set  
> to false:
> 

> There are no parameters (we are performing a simple SELECT * FROM  
> tablename), but the NullPointerException occurs when accessing the  
> START_PARAM_TAG variable.  This variable in AbstractDriverConnection  
> is not initialized.  
> 
> It hits the same portion of code above (testing for the  
> START_PARAM_TAG), and the while loop doesn't execute because it  
> cannot find any instance of "null". 


> I know that I've probably broken  
> this by changing the value of the TAGS and TAG_MARKER variables to  
> something other than null, 

No, you rather fixed it. Those variables (actually, constants) should
never have been null in the first place. This bug was recently introduced
last week, as you painfully noticed. This should be OK in CVS now. Thanks a
lot for you very valuable feedback.

This bug is unfortunately present in release 1.3



<--  Date Index  --> <--  Thread Index  -->

Reply via email to:

Powered by MHonArc.

Copyright © 1999-2005, ObjectWeb Consortium | contact | webmaster.