ObjectWeb Consortium
Search ObjectWeb Mail Archive: 

Advanced Search - Powered by Google


Mail Archive Home | javaservice List | November 2004 Index

<--  Date Index  --> <--  Thread Index  -->

javaservice and jvm X options


I would like to say thank you to all who have participated in the
javaservice project. It has aided me many times in setting up Java
services.

I do have a question. We are trying to use the jvm's -X options to control
the memory allocation of the jvm. We have successfully set up the -Xms and
-Xmx and they seem to work with javaservice. But when we have tried to use
the -Xss setting the jvm does not seem to respond to it. The same exact
settings seem to change the jvm when we run it not as a service, but from
the command line. We have tried both Sun's jvm 1.4.2_03 and 1.4.2_06 (the
latest) with the same results. The parameters in the registry look to be
set correctly. I have downloaded the newest javaservice but the results
are the same.

The details:

Sun's JVM (either 1.4.2_03 or 1.4.2_06)

Install Line:

JavaService -install "ServiceName 3.0"
c:\j2sdk1.4.2_06\jre\bin\server\jvm.dll
"-Djava.class.path=c:\javamail\javamail-1.3.1\mail.jar" "-Xms512M"
"-Xmx512M" "-Xss128k"  -start com.somecompany.EnterpriseServer -params
ServerName solutions logs -stop com.somecompany.EnterpriseServer -method
shutDown -out stdout.log -err stderr.log -current c:\temp

We have also not quoted the -X options with the exact same results.

Suggestions? What I am doing wrong? I am running out of ideas.

Thanks again,

Jay


-- Jay Carney
ProActive Solutions, Inc.
jcarney@xxxxxxxxxxxxxxxxx





<--  Date Index  --> <--  Thread Index  -->

Reply via email to:

Powered by MHonArc.

Copyright © 1999-2005, ObjectWeb Consortium | contact | webmaster.