ObjectWeb Consortium
Search ObjectWeb Mail Archive: 

Advanced Search - Powered by Google

Mail Archive Home | oscar List | June 2004 Index

<--  Date Index  --> <--  Thread Index  -->

RE: [oscar] problem with oscar 1.0.0 and Sun Java

When I use the obr section it "hangs" for a while until the java socket
timeout kicks in.
I couldn't get a connection. I think this has to do with our firewall, it
doesn't allow any direct connections,
rather it should go trough it's proxy. (This is a thing I don't know much

1. Is it possible to set either one :
   - The http proxy for the JVM
   - The http proxy for the OBR bundle

2. Is there any special java coding requierd by a bundle/java program in
order to make it work trough proxies
3. How does one inflicts a security layer.

4. Would a SSL OSGi Service be an usefull service. For example Creating a
ServiceFactory that provides
secure httpsockets. Now every bundle needs to setup secure connections by

Kind regards,

-----Original Message-----
From: Richard S. Hall [mailto:heavy@xxxxxxxxxxxxxx] 
Sent: woensdag 16 juni 2004 10:32
To: nils.ratusznik@xxxxxxxxx
Cc: oscar@xxxxxxxxxxxxx
Subject: Re: [oscar] problem with oscar 1.0.0 and Sun Java

Strange. It works fine for me under Fedora Core 1. I just tested a fresh 
install and I was able to deploy "HTTP Admin" with all of its 
dependencies. Here is the Java I am using:

java version "1.4.2_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_04-b05) Java
HotSpot(TM) Client VM (build 1.4.2_04-b05, mixed mode)

As you can see, it is the same as yours.

There is a pause when you enter the GUI, because it is reading from the 
network, but it shouldn't take that long and it will come back and 
update the table.

Are you sure it is still working under text mode for you?

-> richard

nils.ratusznik@xxxxxxxxx wrote:

>Hi all,
>I just downloaded Oscar 1.0.0 this morning. Once the .oscar directory 
>erased, I installed with GUI shell. I ran Oscar, but when entering in 
>the OBR section, Oscar freezes :p
>Oscar doesn't freeze in text mode. Here is the version of Java I use :
>java version "1.4.2_04"
>Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_04-b05) 
>Java HotSpot(TM) Client VM (build 1.4.2_04-b05, mixed mode
>I'll try with Kaffe 1.1.4 (only for text mode) in the next few days.
>The betas version worked with kaffe in text mode (I didn't try with GUI 
>That's all for my feedback.
>Nils Ratusznik
>You receive this message as a subscriber of the oscar@xxxxxxxxxxxxx 
>mailing list. To unsubscribe: mailto:oscar-unsubscribe@xxxxxxxxxxxxx
>For general help: mailto:sympa@xxxxxxxxxxxxx?subject=help
>ObjectWeb mailing lists service home page: http://www.objectweb.org/wws

<--  Date Index  --> <--  Thread Index  -->

Reply via email to:

Powered by MHonArc.

Copyright © 1999-2005, ObjectWeb Consortium | contact | webmaster.